CVE-2024-4181
Description
A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.
How to fix
- llamaindex llamaindex0.10.13 or later
- llama-index0.10.13 or later
- llama-index-llms-rungpt0.1.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| llamaindex llamaindex | 0.9.47 ≤ v < 0.10.13 | 0.10.13 |
| llama-indexPyPI | v < 0.10.13, 0.9.47 ≤ v < 0.10.13 | 0.10.13 |
| llama-index-llms-rungptPyPI | v < 0.1.3 | 0.1.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.