CVE-2024-41937

Medium

Description

Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.

SeverityMedium
CVSS6.1
Exploit probability—
ProductApache Airflow
PublishedAug 21, 2024
First seenAug 21, 2024

How to fix

Update
  • apache airflow2.10.0 or later
  • apache-airflow2.10.0 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.10.02.10.0
apache-airflowPyPIv < 2.10.02.10.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.