CVE-2024-41964

High

Description

Kirby is a CMS targeting designers and editors. Kirby allows to restrict the permissions of specific user roles. Users of that role can only perform permitted actions. Permissions for creating and deleting languages have already existed and could be configured, but were not enforced by Kirby's frontend or backend code. A permission for updating existing languages has not existed before the patched versions. So disabling the languages.* wildcard permission for a role could not have prohibited updates to existing language definitions. The missing permission checks allowed attackers with Panel access to manipulate the language definitions. The problem has been patched in Kirby 3.6.6.6, Kirby 3.7.5.5, Kirby 3.8.4.4, Kirby 3.9.8.2, Kirby 3.10.1.1, and Kirby 4.3.1. Please update to one of these or a later version to fix the vulnerability. There are no known workarounds for this vulnerability.

SeverityHigh
CVSS8.1
Exploit probability—
ProductKirby
PublishedAug 29, 2024
First seenAug 29, 2024

How to fix

Update
  • getkirby kirby3.6.6.6, 3.7.5.5, 3.8.4.4, 3.9.8.2, 3.10.1.1, 4.3.1 or later
  • getkirby/cms3.6.6.6, 3.7.5.5, 3.8.4.4, 3.9.8.2, 3.10.1.1, 4.3.1 or later

Affected products

ProductAffected versionsFixed in
getkirby kirbyv < 3.6.6.6, 3.7.0 ≤ v < 3.7.5.5, 3.8.0 ≤ v < 3.8.4.4, 3.9.0 ≤ v < 3.9.8.2, 3.10.0 ≤ v < 3.10.1.1, 4.0.0 ≤ v < 4.3.13.6.6.6, 3.7.5.5, 3.8.4.4, 3.9.8.2, 3.10.1.1, 4.3.1
getkirby/cmsPackagistv < 3.6.6.6, 3.7.0 ≤ v < 3.7.5.5, 3.8.0 ≤ v < 3.8.4.4, 3.9.0 ≤ v < 3.9.8.2, 3.10.0 ≤ v < 3.10.1.1, 4.0.0 ≤ v < 4.3.13.6.6.6, 3.7.5.5, 3.8.4.4, 3.9.8.2, 3.10.1.1, 4.3.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-41964 · Kirby · Dark Radar