CVE-2024-42062

High

Description

CloudStack account-users by default use username and password based authentication for API and UI access. Account-users can generate and register randomised API and secret keys and use them for the purpose of API-based automation and integrations. Due to an access permission validation issue that affects Apache CloudStack versions 4.10.0 up to 4.19.1.0, domain admin accounts were found to be able to query all registered account-users API and secret keys in an environment, including that of a root admin. An attacker who has domain admin access can exploit this to gain root admin and other-account privileges and perform malicious operations that can result in compromise of resources integrity and confidentiality, data loss, denial of service and availability of CloudStack managed infrastructure. Users are recommended to upgrade to Apache CloudStack 4.18.2.3 or 4.19.1.1, or later, which addresses this issue. Additionally, all account-user API and secret keys should be regenerated.

SeverityHigh
CVSS7.2
Exploit probability—
ProductApache Cloudstack
PublishedAug 7, 2024
First seenAug 7, 2024

How to fix

Update
  • apache cloudstack4.18.2.3, 4.19.1.1 or later

Affected products

ProductAffected versionsFixed in
apache cloudstack4.10.0.0 ≤ v < 4.18.2.3, 4.19.0.0 ≤ v < 4.19.1.14.18.2.3, 4.19.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-42062 · Apache Cloudstack · Dark Radar