CVE-2024-42356

High

Description

Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the `context` variable is injected into almost any Twig Template and allows to access to current language, currency information. The context object allows also to switch for a short time the scope of the Context as a helper with a callable function. The function can be called also from Twig and as the second parameter allows any callable, it's possible to call from Twig any statically callable PHP function/method. It's not possible as customer to provide any Twig code, the attacker would require access to Administration to exploit it using Mail templates or using App Scripts. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin.

SeverityHigh
CVSS8.3
Exploit probability—
ProductShopware
PublishedAug 8, 2024
First seenAug 8, 2024
Weakness typeCWE-1336CWE-1336

How to fix

Update
  • shopware shopware6.5.8.13, 6.6.5.1 or later
  • shopware/core6.5.8.13, 6.6.5.1 or later
  • shopware/platform6.5.8.13, 6.6.5.1 or later

Affected products

ProductAffected versionsFixed in
shopware shopwarev < 6.5.8.13, 6.6.0.0 ≤ v < 6.6.5.16.5.8.13, 6.6.5.1
shopware/corePackagistv < 6.5.8.13, 6.6.0.0 ≤ v < 6.6.5.16.5.8.13, 6.6.5.1
shopware/platformPackagistv < 6.5.8.13, 6.6.0.0 ≤ v < 6.6.5.16.5.8.13, 6.6.5.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.