CVE-2024-42467

Critical

Description

openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. In versions 3.4.0.M4 through 4.2.0,, the proxy endpoint of openHAB's CometVisu add-on can be accessed without authentication. This proxy-feature can be exploited as Server-Side Request Forgery (SSRF) to induce GET HTTP requests to internal-only servers, in case openHAB is exposed in a non-private network. Furthermore, this proxy-feature can also be exploited as a Cross-Site Scripting (XSS) vulnerability, as an attacker is able to re-route a request to their server and return a page with malicious JavaScript code. Since the browser receives this data directly from the openHAB CometVisu UI, this JavaScript code will be executed with the origin of the CometVisu UI. This allows an attacker to exploit call endpoints on an openHAB server even if the openHAB server is located in a private network. (e.g. by sending an openHAB admin a link that proxies malicious JavaScript.) This issue may lead up to Remote Code Execution (RCE) when chained with other vulnerabilities. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.

SeverityCritical
CVSS10.0
Exploit probability64. percentile1%
ProductOpenhab Web Interface
PublishedAug 12, 2024
First seenAug 12, 2024

How to fix

Update
  • openhab openhab_web_interface4.2.1 or later
  • org.openhab.ui.bundles:org.openhab.ui.cometvisu4.2.1 or later

Affected products

ProductAffected versionsFixed in
openhab openhab_web_interfacev < 4.2.14.2.1
org.openhab.ui.bundles:org.openhab.ui.cometvisuMaven3.4.0.M4 ≤ v < 4.2.14.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.