CVE-2024-42468

Medium

Description

openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. CometVisuServlet in versions prior to 4.2.1 is susceptible to an unauthenticated path traversal vulnerability. Local files on the server can be requested via HTTP GET on the CometVisuServlet. This issue may lead to information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.

SeverityMedium
CVSS5.3
Exploit probability—
ProductOpenhab
PublishedAug 12, 2024
First seenAug 12, 2024

How to fix

Update
  • openhab openhab4.2.1 or later
  • org.openhab.ui.bundles:org.openhab.ui.cometvisu4.2.1 or later

Affected products

ProductAffected versionsFixed in
openhab openhabv < 4.2.14.2.1
org.openhab.ui.bundles:org.openhab.ui.cometvisuMavenv < 4.2.14.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.