CVE-2024-42471
Description
actions/artifact is the GitHub ToolKit for developing GitHub Actions. Versions of `actions/artifact` on the 2.x branch before 2.1.2 are vulnerable to arbitrary file write when using `downloadArtifactInternal`, `downloadArtifactPublic`, or `streamExtractExternal` for extracting a specifically crafted artifact that contains path traversal filenames. Users are advised to upgrade to version 2.1.2 or higher. There are no known workarounds for this issue.
How to fix
- github actions\/artifact2.1.7 or later
- @actions/artifact2.1.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github actions_toolkit | No range specified | — |
| github actions\/artifact | 2.0.0 ≤ v < 2.1.7 | 2.1.7 |
| @actions/artifactnpm | 2.0.0 ≤ v < 2.1.2 | 2.1.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.