CVE-2024-43115
High
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apache Dolphinscheduler
PublishedSep 3, 2025
First seenSep 3, 2025
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache dolphinscheduler3.2.2 or later
- org.apache.dolphinscheduler:dolphinscheduler3.2.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache dolphinscheduler | v < 3.2.2 | 3.2.2 |
| org.apache.dolphinscheduler:dolphinschedulerMaven | v < 3.2.2 | 3.2.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.