CVE-2024-43796
Medium
Description
Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.
SeverityMedium
CVSS5.0
Exploit probability—
Product
Openjsf Express
PublishedSep 10, 2024
First seenSep 10, 2024
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- openjsf express4.20.0 or later
- express4.20.0, 5.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openjsf express | v < 4.20.0, 5.0.0 | 4.20.0 |
| expressnpm | v < 4.20.0, 5.0.0-alpha.1 ≤ v < 5.0.0 | 4.20.0, 5.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.