CVE-2024-44082
Description
In OpenStack Ironic before 26.0.1 and ironic-python-agent before 9.13.1, there is a vulnerability in image processing, in which a crafted image could be used by an authenticated user to exploit undesired behaviors in qemu-img, including possible unauthorized access to potentially sensitive data. The affected/fixed version details are: Ironic: <21.4.3, >=22.0.0 <23.0.2, >=23.1.0 <24.1.2, >=25.0.0 <26.0.1; Ironic-python-agent: <9.4.2, >=9.5.0 <9.7.1, >=9.8.0 <9.11.1, >=9.12.0 <9.13.1.
How to fix
- OpenStack Ironic26.0.1 or later
- OpenStack ironic-python-agent9.13.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| OpenStack Ironic | v ≤ 26.0.1 | 26.0.1 |
| OpenStack ironic-python-agent | v ≤ 9.13.1 | 9.13.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.