CVE-2024-44088

Medium

Description

Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2 Users are recommended to upgrade to version 1.15.2, which fixes the issue.

SeverityMedium
CVSS6.1
Exploit probability—
ProductApache Geode
PublishedOct 14, 2025
First seenOct 14, 2025

How to fix

Update
  • apache geode1.15.2 or later
  • org.apache.geode:geode-web-api1.15.2 or later

Affected products

ProductAffected versionsFixed in
apache geode1.1.0 ≤ v < 1.15.21.15.2
org.apache.geode:geode-web-apiMaven1.1.0 ≤ v < 1.15.21.15.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-44088 · Apache Geode · Dark Radar