CVE-2024-45031
Description
When editing objects in the Syncope Console, incomplete HTML tags could be used to bypass HTML sanitization. This made it possible to inject stored XSS payloads which would trigger for other users during ordinary usage of the application. XSS payloads could also be injected in Syncope Enduser when editing “Personal Information” or “User Requests”: such payloads would trigger for administrators in Syncope Console, thus enabling session hijacking. Users are recommended to upgrade to version 3.0.9, which fixes this issue.
How to fix
- apache syncope3.0.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache syncope | 2.1.0 ≤ v < 3.0.9 | 3.0.9 |
| org.apache.syncope.client:syncope-client-consoleMaven | 2.1.0 ≤ v ≤ 2.1.14 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.