CVE-2024-45033

High

Description

Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider. This issue affects Apache Airflow Fab Provider: before 1.5.2. When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from  CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9  which was addressed in Apache-Airflow 2.7.0 Users are recommended to upgrade to version 1.5.2, which fixes the issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductApache-airflow-providers-fab
PublishedJan 8, 2025
First seenJan 8, 2025
Weakness typeCWE-613CWE-613

How to fix

Update
  • apache apache-airflow-providers-fab1.5.2 or later
  • apache-airflow-providers-fab1.5.2 or later

Affected products

ProductAffected versionsFixed in
apache apache-airflow-providers-fabv < 1.5.21.5.2
apache-airflow-providers-fabPyPIv < 1.5.21.5.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.