CVE-2024-45034

High

Description

Apache Airflow versions before 2.10.1 have a vulnerability that allows DAG authors to add local settings to the DAG folder and get it executed by the scheduler, where the scheduler is not supposed to execute code submitted by the DAG author. Users are advised to upgrade to version 2.10.1 or later, which has fixed the vulnerability.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Airflow
PublishedSep 7, 2024
First seenSep 7, 2024
Weakness typeCWE-250CWE-250

How to fix

Update
  • apache airflow2.10.1 or later
  • apache-airflow2.10.1 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.10.12.10.1
apache-airflowPyPIv < 2.10.12.10.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.