CVE-2024-45053

Critical

Description

Fides is an open-source privacy engineering platform. Starting in version 2.19.0 and prior to version 2.44.0, the Email Templating feature uses Jinja2 without proper input sanitization or rendering environment restrictions, allowing for Server-Side Template Injection that grants Remote Code Execution to privileged users. A privileged user refers to an Admin UI user with the default `Owner` or `Contributor` role, who can escalate their access and execute code on the underlying Fides Webserver container where the Jinja template rendering function is executed. The vulnerability has been patched in Fides version `2.44.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no workarounds.

SeverityCritical
CVSS9.1
Exploit probability—
ProductEthyca Fides
PublishedSep 4, 2024
First seenSep 4, 2024
Weakness typeCWE-1336CWE-1336

How to fix

Update
  • ethyca fides2.44.0 or later
  • ethyca-fides2.44.0 or later

Affected products

ProductAffected versionsFixed in
ethyca fides2.19.0 ≤ v < 2.44.02.44.0
ethyca-fidesPyPI2.19.0 ≤ v < 2.44.02.44.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.