CVE-2024-45216
Description
Improper Authentication vulnerability in Apache Solr. Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.
How to fix
- apache solr8.11.4, 9.7.0 or later
- org.apache.solr:solr8.11.4, 9.7.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache solr | 5.3.0 ≤ v < 8.11.4, 9.0.0 ≤ v < 9.7.0 | 8.11.4, 9.7.0 |
| org.apache.solr:solrMaven | 5.3.0 ≤ v < 8.11.4, 9.0.0 ≤ v < 9.7.0 | 8.11.4, 9.7.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.