CVE-2024-45303

Medium

Description

Discourse Calendar plugin adds the ability to create a dynamic calendar in the first post of a topic to Discourse. Rendering event names can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. The issue is patched in version 0.5 of the Discourse Calendar plugin.

SeverityMedium
CVSS6.1
Exploit probability—
ProductDiscourse Calendar
PublishedSep 12, 2024
First seenSep 12, 2024

How to fix

Update
  • discourse calendar0.5 or later

Affected products

ProductAffected versionsFixed in
discourse calendarv < 0.50.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.