CVE-2024-45384
Description
Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. This could allow an attacker to manipulate a pac4j session cookie. This issue affects Apache Druid versions 0.18.0 through 30.0.0. Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability. While we are not aware of a way to meaningfully exploit this flaw, we nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue and ensuring you have a strong druid.auth.pac4j.cookiePassphrase as a precaution.
How to fix
- apache druid30.0.1 or later
- org.apache.druid.extensions:druid-pac4j30.0.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache druid | 0.18.0 ≤ v < 30.0.1 | 30.0.1 |
| org.apache.druid.extensions:druid-pac4jMaven | 0.18.0 ≤ v < 30.0.1 | 30.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.