CVE-2024-45398

High

Description

Contao is an Open Source CMS. In affected versions a back end user with access to the file manager can upload malicious files and execute them on the server. Users are advised to update to Contao 4.13.49, 5.3.15 or 5.4.3. Users unable to update are advised to configure their web server so it does not execute PHP files and other scripts in the Contao file upload directory.

SeverityHigh
CVSS8.3
Exploit probability—
ProductContao
PublishedSep 17, 2024
First seenSep 17, 2024

How to fix

Update
  • contao contao4.13.49, 5.3.15, 5.4.3 or later
  • contao/core-bundle4.13.49, 5.3.15, 5.4.3 or later

Affected products

ProductAffected versionsFixed in
contao contao4.0.0 ≤ v < 4.13.49, 5.0.0 ≤ v < 5.3.15, 5.4.0 ≤ v < 5.4.34.13.49, 5.3.15, 5.4.3
contao/core-bundlePackagist4.0.0 ≤ v < 4.13.49, 5.0.0 ≤ v < 5.3.15, 5.4.0 ≤ v < 5.4.34.13.49, 5.3.15, 5.4.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.