CVE-2024-45401

High

Description

stripe-cli is a command-line tool for the payment processor Stripe. A vulnerability exists in stripe-cli starting in version 1.11.1 and prior to version 1.21.3 where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update in version 1.21.3 addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability.

SeverityHigh
CVSS7.5
Exploit probability—
ProductStripe Cli
PublishedSep 5, 2024
First seenSep 5, 2024

How to fix

Update
  • stripe stripe_cli1.21.3 or later
  • github.com/stripe/stripe-cli1.21.3 or later

Affected products

ProductAffected versionsFixed in
stripe stripe_cli1.11.1 ≤ v < 1.21.31.21.3
github.com/stripe/stripe-cliGo1.11.1 ≤ v < 1.21.31.21.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.