CVE-2024-45409
Description
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
How to fix
- onelogin ruby-saml1.12.3, 1.17.0 or later
- gitlab gitlab16.11.10, 17.0.8, 17.1.8, 17.2.7, 17.3.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| onelogin ruby-saml | v < 1.12.3, 1.13.0 ≤ v < 1.17.0 | 1.12.3, 1.17.0 |
| omniauth omniauth_saml | v ≤ 1.10.3, 2.0.0, 2.1.0 | — |
| gitlab gitlab | v < 16.11.10, 17.0.0 ≤ v < 17.0.8, 17.1.0 ≤ v < 17.1.8, 17.2.0 ≤ v < 17.2.7, 17.3.0 ≤ v < 17.3.3 | 16.11.10, 17.0.8, 17.1.8, 17.2.7, 17.3.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.