CVE-2024-45411
High
Description
Twig is a template language for PHP. Under some circumstances, the sandbox security checks are not run which allows user-contributed templates to bypass the sandbox restrictions. This vulnerability is fixed in 1.44.8, 2.16.1, and 3.14.0.
SeverityHigh
CVSS8.5
Exploit probability—
Product
Symfony Twig
PublishedSep 9, 2024
First seenSep 9, 2024
Weakness typeCWE-693CWE-693
How to fix
Update
- symfony twig1.44.8, 2.16.1, 3.14.0 or later
- twig/twig1.44.8, 2.16.1, 3.14.0, 3.11.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| symfony twig | 1.0.0 ≤ v < 1.44.8, 2.0.0 ≤ v < 2.16.1, 3.0.0 ≤ v < 3.14.0 | 1.44.8, 2.16.1, 3.14.0 |
| twig/twigPackagist | 1.0.0 ≤ v < 1.44.8, 2.0.0 ≤ v < 2.16.1, 3.12.0 ≤ v < 3.14.0, 3.0.0 ≤ v < 3.11.1 | 1.44.8, 2.16.1, 3.14.0, 3.11.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.