CVE-2024-45479
Critical
Description
SSRF vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Ranger
PublishedJan 21, 2025
First seenJan 21, 2025
Weakness typeCWE-918Server-side request forgery (SSRF)
How to fix
Update
- apache ranger2.5.0 or later
- org.apache.ranger:ranger2.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache ranger | 2.4.0 ≤ v < 2.5.0 | 2.5.0 |
| org.apache.ranger:rangerMaven | 0.5.0 ≤ v < 2.5.0 | 2.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.