CVE-2024-45498

High

Description

Example DAG: example_inlet_event_extra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated attacker with only DAG trigger permission to execute arbitrary commands. If you used that example as the base of your DAGs - please review if you have not copied the dangerous example; see https://github.com/apache/airflow/pull/41873  for more information. We recommend against exposing the example DAGs in your deployment. If you must expose the example DAGs, upgrade Airflow to version 2.10.1 or later.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Airflow
PublishedSep 7, 2024
First seenSep 7, 2024
Weakness typeCWE-116CWE-116

How to fix

Affected products

ProductAffected versionsFixed in
apache airflow2.10.0—
apache-airflowPyPI2.10.0 ≤ v < 2.10.1, v ≤ 2.10.0-NA2.10.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.