CVE-2024-45605

Medium

Description

Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.

SeverityMedium
CVSS6.5
Exploit probability—
ProductSentry
PublishedSep 17, 2024
First seenSep 17, 2024

How to fix

Update
  • sentry sentry24.9.0 or later
  • sentry24.9.0 or later

Affected products

ProductAffected versionsFixed in
sentry sentry23.9.0 ≤ v < 24.9.024.9.0
sentryPyPI23.9.0 ≤ v < 24.9.024.9.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.