CVE-2024-45607
Medium
Description
whatsapp-api-js is a TypeScript server agnostic Whatsapp's Official API framework. It's possible to check the payload validation using the WhatsAppAPI.verifyRequestSignature and expect false when the signature is valid. Incorrect Access Control, anyone using the post or verifyRequestSignature methods to handle messages is impacted. This vulnerability is fixed in 4.0.3.
SeverityMedium
CVSS5.8
Exploit probability—
ProductSecreto31126 Whatsapp-api-js
PublishedSep 12, 2024
First seenSep 12, 2024
Weakness typeCWE-347CWE-347
How to fix
Update
- secreto31126 whatsapp-api-js4.0.3 or later
- whatsapp-api-js4.0.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| secreto31126 whatsapp-api-js | 4.0.0 ≤ v < 4.0.3 | 4.0.3 |
| whatsapp-api-jsnpm | 4.0.0 ≤ v < 4.0.3 | 4.0.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.