CVE-2024-45612
Medium
Description
Contao is an Open Source CMS. In affected versions an untrusted user can inject insert tags into the canonical tag, which are then replaced on the web page (front end). Users are advised to update to Contao 4.13.49, 5.3.15 or 5.4.3. Users unable to upgrade should disable canonical tags in the root page settings.
SeverityMedium
CVSS5.3
Exploit probability—
Product
Contao
PublishedSep 17, 2024
First seenSep 17, 2024
Weakness typeCWE-20Improper input validation
How to fix
Update
- contao contao4.13.49, 5.3.15, 5.4.3 or later
- contao/core-bundle4.13.49, 5.3.15, 5.4.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| contao contao | 4.13.0 ≤ v < 4.13.49, 5.3.0 ≤ v < 5.3.15, 5.4.0 ≤ v < 5.4.3 | 4.13.49, 5.3.15, 5.4.3 |
| contao/core-bundlePackagist | 4.13.0 ≤ v < 4.13.49, 5.0.0 ≤ v < 5.3.15, 5.4.0 ≤ v < 5.4.3 | 4.13.49, 5.3.15, 5.4.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.