CVE-2024-45626

Medium

Description

Apache James server JMAP HTML to text plain implementation in versions below 3.8.2 and 3.7.6 is subject to unbounded memory consumption that can result in a denial of service. Users are recommended to upgrade to version 3.7.6 and 3.8.2, which fix this issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache James Server
PublishedFeb 6, 2025
First seenFeb 6, 2025

How to fix

Update
  • apache james_server3.7.6, 3.8.2 or later
  • org.apache.james:james-server-jmap-draft3.8.2, 3.7.6 or later

Affected products

ProductAffected versionsFixed in
apache james_serverv < 3.7.6, 3.8.0 ≤ v < 3.8.23.7.6, 3.8.2
org.apache.james:james-server-jmap-draftMaven3.8.0 ≤ v < 3.8.2, v < 3.7.63.8.2, 3.7.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.