CVE-2024-45693
Description
Users logged into the Apache CloudStack's web interface can be tricked to submit malicious CSRF requests due to missing validation of the origin of the requests. This can allow an attacker to gain privileges and access to resources of the authenticated users and may lead to account takeover, disruption, exposure of sensitive data and compromise integrity of the resources owned by the user account that are managed by the platform. This issue affects Apache CloudStack from 4.15.1.0 through 4.18.2.3 and 4.19.0.0 through 4.19.1.1 Users are recommended to upgrade to Apache CloudStack 4.18.2.4 or 4.19.1.2, or later, which addresses this issue.
How to fix
- apache cloudstack4.18.2.4, 4.19.1.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cloudstack | 4.15.1.0 ≤ v < 4.18.2.4, 4.19.0.0 ≤ v < 4.19.1.2 | 4.18.2.4, 4.19.1.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.