CVE-2024-45719
Low
Description
Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: through 1.4.0. The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.
SeverityLow
CVSS2.6
Exploit probability—
Product
Apache Answer
PublishedNov 22, 2024
First seenNov 22, 2024
Weakness typeCWE-326CWE-326
How to fix
Update
- apache answer1.4.1 or later
- github.com/apache/incubator-answer1.4.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache answer | v < 1.4.1 | 1.4.1 |
| github.com/apache/incubator-answerGo | v < 1.4.1 | 1.4.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.