CVE-2024-45772

Medium

Description

Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator. This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.

SeverityMedium
CVSS5.1
Exploit probability—
ProductApache Lucene Replicator
PublishedSep 30, 2024
First seenSep 30, 2024

How to fix

Update
  • apache lucene_replicator9.12.0 or later
  • org.apache.lucene:lucene-replicator9.12.0 or later

Affected products

ProductAffected versionsFixed in
apache lucene_replicator4.4.0 ≤ v < 9.12.09.12.0
org.apache.lucene:lucene-replicatorMaven4.4.0 ≤ v < 9.12.09.12.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.