CVE-2024-45784

High

Description

Apache Airflow versions before 2.10.3 contain a vulnerability that could expose sensitive configuration variables in task logs. This vulnerability allows DAG authors to unintentionally or intentionally log sensitive configuration variables. Unauthorized users could access these logs, potentially exposing critical data that could be exploited to compromise the security of the Airflow deployment. In version 2.10.3, secrets are now masked in task logs to prevent sensitive configuration variables from being exposed in the logging output. Users should upgrade to Airflow 2.10.3 or the latest version to eliminate this vulnerability. If you suspect that DAG authors could have logged the secret values to the logs and that your logs are not additionally protected, it is also recommended that you update those secrets.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Airflow
PublishedNov 15, 2024
First seenNov 15, 2024
Weakness typeCWE-1295CWE-1295

How to fix

Update
  • apache airflow2.10.3 or later
  • airflow2.10.3 or later
  • apache-airflow2.10.3 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.10.32.10.3
airflowPyPIv < 2.10.32.10.3
apache-airflowPyPIv < 2.10.32.10.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.