CVE-2024-47249

Medium

Description

Improper Validation of Array Index vulnerability in Apache NimBLE. Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.

SeverityMedium
CVSS5.0
Exploit probability—
ProductApache Nimble
PublishedNov 26, 2024
First seenNov 26, 2024
Weakness typeCWE-129CWE-129

How to fix

Affected products

ProductAffected versionsFixed in
apache nimblev < 1.8.01.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.