CVE-2024-47552

Critical

Description

Deserialization of Untrusted Data vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): from 2.0.0 before 2.2.0. Severity Justification: The Apache Seata security team assesses the severity of this vulnerability as "Low" due to stringent real-world mitigating factors. First, the vulnerability is strictly isolated to the Raft cluster mode, an optional and non-default feature introduced in v2.0.0, while most users rely on the unaffected traditional architecture. Second, Seata is an internal middleware; communication between TC and RM/TM occurs entirely within trusted internal networks. An attacker would require prior, unauthorized access to the Intranet to exploit this, making external exploitation highly improbable. Users are recommended to upgrade to version 2.2.0, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Seata
PublishedMar 20, 2025
First seenMar 20, 2025

How to fix

Update
  • apache seata2.2.0 or later
  • org.apache.seata:seata-config-core2.2.0 or later

Affected products

ProductAffected versionsFixed in
apache seata2.0.0 ≤ v < 2.2.02.2.0
org.apache.seata:seata-config-coreMaven2.0.0 ≤ v < 2.2.02.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.