CVE-2024-47554
Medium
Description
Uncontrolled Resource Consumption vulnerability in Apache Commons IO. The org.apache.commons.io.input.XmlStreamReader class may excessively consume CPU resources when processing maliciously crafted input. This issue affects Apache Commons IO: from 2.0 before 2.14.0. Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.
SeverityMedium
CVSS4.3
Exploit probability—
Product
Apache Commons Io
PublishedOct 3, 2024
First seenOct 3, 2024
Weakness typeCWE-400Uncontrolled resource consumption
How to fix
Update
- apache commons_io2.14.0 or later
- commons-io:commons-io2.14.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache commons_io | 2.0 ≤ v < 2.14.0 | 2.14.0 |
| netapp active_iq_unified_manager | No range specified | — |
| netapp bluexp | No range specified | — |
| netapp e-series_santricity_unified_manager | No range specified | — |
| netapp e-series_santricity_web_services_proxy | No range specified | — |
| netapp ontap_tools | 9, 10 | — |
| netapp santricity_storage_plugin | No range specified | — |
| netapp snapcenter | No range specified | — |
| commons-io:commons-ioMaven | 2.0 ≤ v < 2.14.0 | 2.14.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.