CVE-2024-47778

High

Description

GStreamer is a library for constructing graphs of media-handling components. An OOB-read vulnerability has been discovered in gst_wavparse_adtl_chunk within gstwavparse.c. This vulnerability arises due to insufficient validation of the size parameter, which can exceed the bounds of the data buffer. As a result, an OOB read occurs in the following while loop. This vulnerability can result in reading up to 4GB of process memory or potentially causing a segmentation fault (SEGV) when accessing invalid memory. This vulnerability is fixed in 1.24.10.

SeverityHigh
CVSS7.5
Exploit probability—
ProductGstreamer
PublishedDec 12, 2024
First seenDec 12, 2024

How to fix

Update
  • gstreamer gstreamer1.24.10 or later

Affected products

ProductAffected versionsFixed in
gstreamer gstreamerv < 1.24.101.24.10

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.