CVE-2024-48019
Medium
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Files or Directories Accessible to External Parties vulnerability in Apache Doris. Application administrators can read arbitrary files from the server filesystem through path traversal. Users are recommended to upgrade to version 2.1.8, 3.0.3 or later, which fixes the issue.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Apache Doris
PublishedFeb 4, 2025
First seenFeb 4, 2025
Weakness typeCWE-22Path traversalCWE-552CWE-552
How to fix
Update
- apache doris2.1.8, 3.0.3 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache doris | 2.1.0 ≤ v < 2.1.8, 3.0.0 ≤ v < 3.0.3 | 2.1.8, 3.0.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.