CVE-2024-48944
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api endpoint open for service. This issue affects Apache Kylin: from 5.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2, which fixes the issue.
How to fix
- apache kylin5.0.2 or later
- org.apache.kylin:kylin-common-server5.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache kylin | 5.0.0 ≤ v < 5.0.2 | 5.0.2 |
| org.apache.kylin:kylin-common-serverMaven | 5.0.0 ≤ v < 5.0.2 | 5.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.