CVE-2024-49754

High

Description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the API-Access page allows authenticated users to inject arbitrary JavaScript through the "token" parameter when creating a new API token. This vulnerability can result in the execution of malicious code in the context of other users' sessions, compromising their accounts and enabling unauthorized actions. This vulnerability is fixed in 24.10.0.

SeverityHigh
CVSS7.5
Exploit probability—
ProductLibrenms
PublishedNov 15, 2024
First seenNov 15, 2024

How to fix

Update
  • librenms librenms24.10.0 or later
  • librenms/librenms24.10.0 or later

Affected products

ProductAffected versionsFixed in
librenms librenmsv < 24.10.024.10.0
librenms/librenmsPackagistv < 24.10.024.10.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.