CVE-2024-50378

Medium

Description

Airflow versions before 2.10.3 have a vulnerability that allows authenticated users with audit log access to see sensitive values in audit logs which they should not see. When sensitive variables were set via airflow CLI, values of those variables appeared in the audit log and were stored unencrypted in the Airflow database. While this risk is limited to users with audit log access, it is recommended to upgrade to Airflow 2.10.3 or a later version, which addresses this issue. Users who previously used the CLI to set secret variables should manually delete entries with those variables from the log table.

SeverityMedium
CVSS4.9
Exploit probability—
ProductApache Airflow
PublishedNov 8, 2024
First seenNov 8, 2024
Weakness typeCWE-201CWE-201

How to fix

Update
  • apache airflow2.10.3 or later
  • apache-airflow2.10.3 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.10.32.10.3
apache-airflowPyPIv < 2.10.32.10.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-50378 · Apache Airflow · Dark Radar