CVE-2024-5126

Medium

Description

An improper access control vulnerability exists in the lunary-ai/lunary repository, specifically within the versions.patch functionality for updating prompts. Affected versions include 1.2.2 up to but not including 1.2.25. The vulnerability allows unauthorized users to update prompt details due to insufficient access control checks. This issue was addressed and fixed in version 1.2.25.

SeverityMedium
CVSS6.5
Exploit probability—
ProductLunary
PublishedJun 6, 2024
First seenJun 6, 2024

How to fix

Update
  • lunary lunary1.2.25 or later

Affected products

ProductAffected versionsFixed in
lunary lunary1.2.2 ≤ v < 1.2.251.2.25

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.