CVE-2024-5131
Medium
Description
An Improper Access Control vulnerability exists in the lunary-ai/lunary repository, affecting versions up to and including 1.2.2. The vulnerability allows unauthorized users to view any prompts in any projects by supplying a specific prompt ID to an endpoint that does not adequately verify the ownership of the prompt ID. This issue was fixed in version 1.2.25.
SeverityMedium
CVSS6.5
Exploit probability—
ProductLunary
PublishedJun 6, 2024
First seenJun 6, 2024
How to fix
Update
- lunary lunary1.2.25 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| lunary lunary | v < 1.2.25 | 1.2.25 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.