CVE-2024-51496

Medium

Description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Reflected Cross-Site Scripting (XSS) vulnerability in the "metric" parameter of the "/wireless" and "/health" endpoints allows attackers to inject arbitrary JavaScript. This vulnerability results in the execution of malicious code when a user accesses the page with a malicious "metric" parameter, potentially compromising their session and allowing unauthorized actions. This vulnerability is fixed in 24.10.0.

SeverityMedium
CVSS4.8
Exploit probability—
ProductLibrenms
PublishedNov 15, 2024
First seenNov 15, 2024

How to fix

Update
  • librenms librenms24.10.0 or later
  • librenms/librenms24.10.0 or later

Affected products

ProductAffected versionsFixed in
librenms librenmsv < 24.10.024.10.0
librenms/librenmsPackagistv < 24.10.024.10.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.