CVE-2024-51567
Description
upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
How to fix
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
CISA due date: Nov 28, 2024- cyberpanel cyberpanel2.3.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| cyberpanel cyberpanel | v < 2.3.8 | 2.3.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.