CVE-2024-5197

Critical

Description

There exists interger overflows in libvpx in versions prior to 1.14.1. Calling vpx_img_alloc() with a large value of the d_w, d_h, or align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. Calling vpx_img_wrap() with a large value of the d_w, d_h, or stride_align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. We recommend upgrading to version 1.14.1 or beyond

SeverityCritical
CVSS9.1
Exploit probability—
ProductWebmproject Libvpx
PublishedJun 3, 2024
First seenJun 3, 2024

How to fix

Update
  • webmproject libvpx1.14.1 or later

Affected products

ProductAffected versionsFixed in
webmproject libvpxv < 1.14.11.14.1
debian debian_linux10.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.