CVE-2024-52279
Medium
Description
Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
SeverityMedium
CVSS5.3
Exploit probability—
Product
Apache Zeppelin
PublishedAug 3, 2025
First seenAug 3, 2025
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache zeppelin0.12.0 or later
- org.apache.zeppelin:zeppelin-jdbc0.12.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache zeppelin | 0.11.1 ≤ v < 0.12.0 | 0.12.0 |
| org.apache.zeppelin:zeppelin-jdbcMaven | 0.11.1 ≤ v < 0.12.0 | 0.12.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.