CVE-2024-52317
Description
Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users. This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
How to fix
- apache tomcat9.0.96, 10.1.31 or later
- org.apache.tomcat.embed:tomcat-embed-core9.0.96, 10.1.31, 11.0.0 or later
- org.apache.tomcat:tomcat-coyote9.0.96, 10.1.31, 11.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 9.0.92 ≤ v < 9.0.96, 10.1.27 ≤ v < 10.1.31, 11.0.0 | 9.0.96, 10.1.31 |
| org.apache.tomcat.embed:tomcat-embed-coreMaven | 9.0.92 ≤ v < 9.0.96, 10.1.27 ≤ v < 10.1.31, 11.0.0-M23 ≤ v < 11.0.0 | 9.0.96, 10.1.31, 11.0.0 |
| org.apache.tomcat:tomcat-coyoteMaven | 9.0.92 ≤ v < 9.0.96, 10.1.27 ≤ v < 10.1.31, 11.0.0-M23 ≤ v < 11.0.0 | 9.0.96, 10.1.31, 11.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.