CVE-2024-52520
Medium
Description
Nextcloud Server is a self hosted personal cloud system. Due to a pre-flighted HEAD request, the link reference provider could be tricked into downloading bigger websites than intended, to find open-graph data. It is recommended that the Nextcloud Server is upgraded to 28.0.10 or 29.0.7 and Nextcloud Enterprise Server is upgraded to 27.1.11.8, 28.0.10 or 29.0.7.
SeverityMedium
CVSS5.7
Exploit probability—
Product
Nextcloud Server
PublishedNov 15, 2024
First seenNov 15, 2024
Weakness typeCWE-400Uncontrolled resource consumption
How to fix
Update
- nextcloud nextcloud_server27.1.11.8, 28.0.10, 29.0.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | 27.0.0 ≤ v < 27.1.11.8, 28.0.0 ≤ v < 28.0.10, 29.0.0 ≤ v < 29.0.7 | 27.1.11.8, 28.0.10, 29.0.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.