CVE-2024-52525
Description
Nextcloud Server is a self hosted personal cloud system. Under certain conditions the password of a user was stored unencrypted in the session data. The session data is encrypted before being saved in the session storage (Redis or disk), but it would allow a malicious process that gains access to the memory of the PHP process, to get access to the cleartext password of the user. It is recommended that the Nextcloud Server is upgraded to 28.0.12, 29.0.9 or 30.0.2.
How to fix
- nextcloud nextcloud_server28.0.12, 29.0.9, 30.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | 28.0.0 ≤ v < 28.0.12, 29.0.0 ≤ v < 29.0.9, 30.0.0 ≤ v < 30.0.2 | 28.0.12, 29.0.9, 30.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.